GUVI
Back

Doubt in Codekata basics problem

Created 2 years ago
261 Views
3 Comments
GokilaE
@GokilaE
GokilaE
@GokilaEProfile is locked. Login

Write a code get an integer number as input and print the sum of the digits.

Input Description:
A single line containing an integer.

Output Description:
Print the sum of the digits of the integer.

Sample Input :

124

Sample Output :

7

n = int(input())
r = 0
while n>0:
    d = n%10
    r = r+d
    n = n/10
print(r)

I got an output 7.777777777777778. I don't want float an output i need an exact 7. How to be solved above problem, please anyone can help.

Comments (3)
Please login to comment.
 
Powered by habitate.io Habitate